DOCUMENT:Q222060  16-MAY-2002  [winnt]
TITLE   :Err Msg: "Error 5: Access denied" When Using PPTP with RAS
PRODUCT :Microsoft Windows NT
PROD/VER:winnt:4.0,4.0 SP3,4.0 SP4
OPER/SYS:
KEYWORDS:kbnetwork kbWinNT400sp5fix

======================================================================
-------------------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Windows NT Server versions 4.0, 4.0 SP3, 4.0 SP4 
 - Microsoft Windows NT Workstation versions 4.0, 4.0 SP3, 4.0 SP4 
-------------------------------------------------------------------------------

SYMPTOMS
========

When you attempt to make a PPTP connection from a Windows NT 4.0 Service Pack 4
(SP4) client to a Windows NT 4.0 SP4 PPTP server running RAS or Routing and
Remote Access Service (RRAS), the initial authentication attempt may not work
and display an "Error 5: Access Denied" error message. This problem can also
occur if your PPTP client and server are running the post-Service Pack 3
PPTP3-fix hotfix.

CAUSE
=====

This problem occurs because there is a timing mismatch during the authentication
process between the client and server using MSCHAPv2 authentication.

RESOLUTION
==========

To resolve this problem, obtain the latest service pack for Microsoft Windows NT
4.0. For additional information, please see the following article in the
Microsoft Knowledge Base:

   Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS
======

Microsoft has confirmed this to be a problem in Windows NT 4.0. This problem was
first corrected in Windows NT 4.0 Service Pack 5.

MORE INFORMATION
================

The hotfix must be applied to the PPTP client computer, installing the hotfix or
Windows NT 4.0 Service Pack 5 (SP5) to the PPTP server will not fix this
problem. In the very rare case where the client is another RRAS server, there is
also a RRAS-specific fix available if you choose to not install SP5.

Additional query words: pptp authentication MSCHAP MSCHAPv2 RRAS RAS

======================================================================
Keywords          : kbnetwork kbWinNT400sp5fix 
Technology        : kbWinNTsearch kbWinNTWsearch kbWinNTW400 kbWinNTW400search kbWinNT400search kbWinNTW400sp4 kbWinNTW400sp3 kbWinNTSsearch kbWinNTS400sp4 kbWinNTS400sp3 kbWinNTS400search kbWinNTS400
Version           : winnt:4.0,4.0 SP3,4.0 SP4
Hardware          : ALPHA x86
Issue type        : kbbug
Solution Type     : kbfix

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS
PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND.  MICROSOFT DISCLAIMS
ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  IN NO
EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR
ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL,
CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF
MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.  SOME STATES DO NOT ALLOW THE EXCLUSION
OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES
SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 2002.