DOCUMENT:Q190949  18-DEC-1999  [sms]
TITLE   :SMS: PREINST /SYNCPARENT Leaves Blank Records in Machine Groups
PRODUCT :Microsoft Systems Management Server
PROD/VER:winnt:1.2
OPER/SYS:
KEYWORDS:

======================================================================
-------------------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Systems Management Server version 1.2 
-------------------------------------------------------------------------------

SYMPTOMS
========

When you perform a PREINST /SYNCPARENT to update inventory at a parent site,
records that are deleted from the child site may result in blank records in your
Systems Management Server machine groups on the parent site.

CAUSE
=====

When the PREINST /SYNCPARENT process runs, the child site sends all of its
inventory to the parent. When the parent processes this inventory, it will
remove any records from its database that have been deleted on the child site.
When the parent site deletes these records, it does not check to see if the
deleted computers are members of any Systems Management Server machine groups.
The machine groups will be left with blank records that point to the computers
that were deleted.

WORKAROUND
==========

To work around this problem, try any one of the following:

 - Manually delete each record from the Parent sites when they are deleted from
   the child site.

-or-

 - After going through the PREINST /SYNCPARENT process, look at each machine
   group on the parent site and delete any blank records.

-or-

 - Use the DELMIF trigger to automatically delete all computers from the parent
   when a computer is deleted from the child site. For more information on the
   DELMIF trigger, see the following article in the Microsoft Knowledge Base;

   Q188051 SMS: Delmif.exe Syntax, Description, and Usage

STATUS
======

Microsoft has confirmed this to be a problem in Systems Management Server
version 1.2. We are researching this problem and will post additional
information here in the Microsoft Knowledge Base as it becomes available.

Additional query words: prodsms

======================================================================
Keywords          :  
Technology        : kbSMSSearch kbSMS120
Version           : winnt:1.2
Issue type        : kbbug
Solution Type     : kbpending

=============================================================================

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS
PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND.  MICROSOFT DISCLAIMS
ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  IN NO
EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR
ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL,
CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF
MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.  SOME STATES DO NOT ALLOW THE EXCLUSION
OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES
SO THE FOREGOING LIMITATION MAY NOT APPLY.

Copyright Microsoft Corporation 1999.