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Chapter 1
Overview

This TechNote explains how to install and configure a COMPAQ
SYSTEMPRO Personal Computer System running SCO UNIX and ORACLE
RDBMS as a database server in a NetWare network. The result is a NetWare
workstation that can transparently access ORACLE data from a COMPAQ
and SCO UNIX server. The end user need not know that the database
information is coming from a UNIX-based server. This TechNote discusses
two methods of implementation: the SPX/IPX Integrated Platform and the
TCP/IP Integrated Platform.   

Client-Server Computing
Client-server computing is based on the concept of cooperative processing
between "front-end" and "back-end" computers each running separate
programs that communicate with each other. The most common form of
client-server computing is based on a distributed relational database model
using these two major components.    

The front-end computer is a personal computer and/or workstation used for
data entry, graphical display, and to locally process subsets of data from back-
end database servers. In contrast to the traditional minicomputer/ mainframe
model of computing, less expensive front-end PCs and workstations are used
to off load expensive host processing cycles.

The second component is the back-end database engine. Back-end servers can
intelligently select and send subsets of data to front-end PCs for further
processing. These sophisticated back-end database engines offer significantly
more capacity, security, data integrity, and intelligence than the earlier PC
LAN database servers.
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Computing Models
The computing models defined in this TechNote are based on organizational
productivity. These models integrate client-server computing into corporate-
wide networks, provide the individual with access to corporate data, and
preserve personal productivity computing. Corporate minicomputer
applications are being rewritten for client-server platforms in a process called
"applications rightsizing."   

As applications migrate from minicomputers to client-server platforms, back-
end servers must offer better price, performance, and functionality levels than
the platforms they replace. Together, Compaq Computer Corporation and The
Santa Cruz Operation, Inc. (SCO) offer database server solutions that support
high-performance multiprocessor technology, open systems solutions, robust
communications, and robust multitasking capabilities. These qualities make a
COMPAQ and SCO UNIX platform an ideal choice for a database server.

SPX/IPX Platform Overview
This platform uses only the SPX/IPX protocol stack for both NetWare services
as well as the ORACLE database services. This TechNote explains:   

■ This "single-protocol" platform   

■ Installing SPX/IPX in an SCO UNIX and ORACLE database server

■ Accessing the database server from a NetWare workstation

There are two primary advantages of the SPX/IPX Integrated Platform over a
TCP/IP Integrated platform. The SPX/IPX Integrated Platform is less
expensive and easier to administer. No additional protocol software is required
at the workstation.
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TCP/IP Platform Overview
This platform uses a "dual-protocol" stack of both SPX/IPX and TCP/IP
protocols at the workstation. NetWare services are available with the SPX/IPX
stack and the ORACLE database services are available with the TCP/IP stack.
The workstation software that provides this dual stack is LAN WorkPlace for
DOS from Novell.     

The primary advantage of the TCP/IP Integrated Platform is that it offers SCO
UNIX services as well as standard NetWare services. This means
that all of the capabilities of UNIX are available to the NetWare user.

Front-End Tools
This TechNote details the installation of two popular front-end tools:
PowerBuilder and Forest & Trees. PowerBuilder is used to develop
client-server applications that can input data as well as query existing
databases. Forest & Trees is used to perform ad hoc queries and
to develop applications that query existing databases. It also has the ability to
process the data further in a variety of interesting ways, such as graphing data,
providing automatic querying with alarms, and providing drill-down views of
data (windows with successively more detail).    

Refer to the documentation that comes with these products for more
information.
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Chapter 2
SPX/IPX Platform

This chapter provides you with the information to produce the SPX/IPX
model. The following sections describe the SPX/IPX Platform and provide
installation instructions.   

Platform Components
The following figure illustrates the entire SPX/IPX Platform:

Figure 2-1.  SPX/IPX Platform
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The following table lists the components you will install on the NetWare
server, the Windows workstation, and the SCO UNIX database server using
this TechNote:   

Table 2-1
Software Components to Install

NetWare Server Windows Workstation Database Server

none SQL*Net SPX/IPX for DOS
Version 1.1

SCO LLI Drivers
Version 3.1

PowerBuilder Version 2.0 SCO IPX/SPX
Version 1.0

Forest & Trees Version 2.0c SQL*Net SPX/IPX for UNIX
Version 1.1.0

Platform Concepts
It is important to understand some of the basic concepts used in this platform.
The following sections explain SPX/IPX network addressing and operating
system transparency.

SPX/IPX Network Addressing

NetWare network addresses are based on two numbers: the "external network
number" and an "internal network number."       

The external network number identifies a "logical network" and must be the
same for all servers on the same logical network. It is possible for
two logical networks to share the same physical network cable.

The internal network number refers to a specific machine and must be unique
within a given external logical network. Usually, this address is written in
hexadecimal notation. In this TechNote, we use the hexadecimal number,
0x12A34B, for the workstation.
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Operating System Transparency and ORACLE
Connect Strings

To establish a session with an ORACLE database server, the client must send
a connect string to the server along with an ORACLE login ID and
an ORACLE password. The connect string usually contains three fields of
information: the protocol abbreviation, the server name, and the database
identifier. For example, to log in via SPX/IPX to a UNIX server named
unxserv where an ORACLE database identified as orac is running, you would
use the following connect string:     

x:unxserv:orac

The only change needed to log in to the same server and database via TCP/IP
is to replace the letter "x" in the connect string with the letter "t."

t:unxserv:orac

The connect string is nearly identical for connecting to a NetWare and
ORACLE server. For example:

x:orasrv
t:nwserv:orasrv

The result is that the end user need not know whether the data source is an
ORACLE server running on UNIX or running on NetWare.

Pre-Installation Assumptions
This TechNote assumes two existing conditions:

■ An operational NetWare network (NetWare 3.11 server with SPX/IPX
is communicating with an MS-DOS workstation running Microsoft
Windows).

■ A COMPAQ SYSTEMPRO running SCO UNIX and ORACLE as a
database server is physically connected on the same network, but has no
network interface card (NIC) drivers or protocol stacks installed.
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The following figure illustrates the configuration you should have in place
before beginning this installation:   

Figure 2-2.  Pre-installed Software

If you have not completed this type of installation, you can refer to the
Compaq and Novell Integration ToolKit and the Compaq and SCO
Client-Server ToolKit, both published by Compaq Computer Corporation.
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SCO UNIX Database Server

The following list describes the database server components you should have
installed before you begin:   

■ COMPAQ SYSTEMPRO installed as a server

■ Appropriate Ethernet network interface card (NIC) and cable

■ SCO UNIX System V/386 Release 3.2 Version 4

■ SCO UNIX Maintenance Supplement 4.1.0d

■ COMPAQ Supplement for SCO UNIX
(COMPAQ EFS for SCO UNIX Version 1.4)

■ SCO UNIX Development System Release 3.2 Version 4

■ ORACLE Relational Database Management System (RDBMS) Version
6.0.33 (includes SQL*Net TCP/IP for UNIX)

NetWare Server

The following list describes the NetWare server components you should have
installed before you begin:   

■ COMPAQ 386 or 486-based server (minimum)

■ NE2000 Ethernet (or other suitable NIC)

■ NetWare v3.11 from Compaq
(includes SPX/IPX)

In addition, be sure to have a working SPX/IPX connection. The following
display is an example of the assumed autoexec.ncf  file for the NetWare
server:   

file server name NWFS1
ipx internal net 12A34B

bind IPX to ipxlan net=101



.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
2-6    SPX/IPX Platform

Windows Workstation

The following list describes the workstation components you should have
installed before you begin:   

■ COMPAQ 386sx-based PC (minimum)

■ NE2000 Ethernet (or other suitable NIC)

■ MS-DOS 5.0, as published by Compaq, located in the directory, c:\dos

■ Microsoft Windows 3.1 located in the directory, c:\windows

■ NetWare 3.11 Workstation Software in the directory, c:\

In addition, the Windows workstation should be able to validate the SPX/IPX
connection by logging in to the NetWare server. The following displays are
examples of the assumed autoexec.bat and config.sys files for the Windows
workstation:

autoexec.bat    

c:\windows\smartdrv.exe
prompt $p $g
path c:\windows;c:\dos
temp=c:\windows\temp
c:\ipx.com
c:\netx.com

config.sys  

device=c:\windows\himem.sys
files=20
buffers=30
stacks=9,256
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Installing the SCO UNIX Database Server
During installation, certain configuration files are altered. The following table
lists the files altered during the installation procedures:    

Table 2-2
Altered SCO UNIX Database Server Configuration Files

Procedure File

SPX/IPX configuration /etc/ipx.d/NPSConfig

ORACLE configuration $ORACLE_HOME/.profile

The procedures to install the SCO UNIX database server include:

■ Installing the SCO LLI drivers and SCO IPX/SPX with custom

■ Configuring the LLI chain, the NIC driver, and the protocol stack
with netconfig

■ Configuring a software-configurable NIC

■ Validating the NIC installation

■ Installing ORACLE SQL*Net SPX/IPX

Complete the procedures in the order presented in the following sections.
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Installation Tips
■ To verify software versions of ORACLE, enter     

/u/oracle/install/prtversion.sh -f list

Then, view the list file.

■ To install UNIX software from a 5 1/4-inch drive 1
using custom, enter

custom -m  /dev/rfd196ds15

Installing SCO LLI Drivers and SCO IPX/SPX

The following procedures use the custom utility to install both the LLI drivers
and SCO IPX/SPX.

SCO LLI Drivers

To install the LLI drivers, complete the following steps:  

1. Start the custom utility from the UNIX system prompt by entering

custom

2. In sequence, select Install → A New Product → Packages.

3. After inserting the SCO LLI Drivers diskette at the prompt,
press ENTER.

4. Use the space bar to select the NIC you are using. For example, if you
want to install the SMC/Western Digital driver, select wdn and press
ENTER.

5. When prompted for the diskette (already in place), press ENTER.

6. After reading the netconfig prompt, press ENTER.

!
IMPORTANT:  You cannot use netconfig to configure the
driver until after you install the protocol stack.
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SCO IPX/SPX

Continue using the custom utility to install SCO IPX/SPX:  

1. Select Install → A New Product → Entire Product.

2. After inserting the SCO IPX/SPX diskette at the prompt, press
ENTER.

3. To continue, press ENTER.

4. After reading the netconfig prompt, press ENTER.

5. Quit custom by entering

q

6. Confirm the exit by entering

y
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Configuring the LLI Chain,
the NIC Driver, and the Protocol Stack

The following procedures use the netconfig utility to configure the LLI chain,
the NIC driver, and the protocol stack.

LLI Chain

To configure the LLI chain, complete the following steps:   

1. At the system prompt, enter

netconfig

2. Select 1-add a chain, by entering

1

3. Select the top level of the chain, 1-sco_ipx, by entering

1

4. Select the next level of the chain, 1-wdn0, by entering

1

5. To add the chain (sco_ipx  wdn0), enter

y
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NIC Driver

Continue using netconfig to configure the NIC driver as follows:   

1. "IRQ," enter the interrupt number. For example:

2

2. For the "I/O Base Address," enter the appropriate address.
For example:

240

3. For the "RAM Base Address," enter the appropriate address.
For example:

d0000

4. For the "RAM Size in K," enter the appropriate size. For example:

16

Protocol Stack

Continue using netconfig to configure the protocol stack as follows:   

1. For the "MAX # of NVT LOGINS," enter

16

2. For the "SAP REPLY DELAY," enter

1

3. For the "INTERNAL NETWORK NUMBER," enter the appropriate
number. For example:

0x12A34B

4. For the "LAN TYPE," indicate 802.3 by entering

2

5. For the "PROTOCOL NUMBERS," indicate the default (-2)
by entering

2
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6. At the "Do you wish to add pseudo-ttys?" prompt, enter

n

7. Press ENTER to continue.

8. Quit netconfig by entering

q

9. When asked if you want to relink the kernel now, answer yes
by entering

y

10. When asked if you want this kernel to boot by default, answer yes
by entering

y

11. When asked if you want the kernel environment rebuilt, answer yes
by entering

y

 Do not reboot the system yet. Continue to the next procedure,
"Configuring a Software-Configurable NIC."
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Configuring a Software-Configurable NIC

With some network interface cards, you can configure the communications
parameters with software. This section applies specifically to such hardware
and uses SMC/Western Digital NICs as examples. In such cases it is useful to
configure the NIC driver before configuring the NIC. (See "Configuring the
NIC Driver" earlier in this chapter.) Following this order ensures that UNIX
can resolve any hardware conflicts first. Once you configure the driver, use
the following procedure to configure software-configurable NICs.  

1. in single-user mode by entering

init 1

2. Start the appropriate setup program for your NIC. For example, to
configure SMC/Western Digital cards, enter

wdnsetup

3. When asked if you want to change the setup, answer yes by entering

y

4. For the "I/O Base Address," enter the appropriate address.
For example:

240

5. For the "IRQ," enter the interrupt number. For example:

2

6. For the "RAM Base Address," enter the appropriate address.
For example:

0D0000

7. Enable "Link Integrity," by entering

e

8. Disable ROM by entering

y

9. To save the new setup, enter

y
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Validating the NIC Installation

To validate the NIC installation, complete the following steps:   

1. Reboot the system by entering

init 6

2. Examine the Boot Screen. If the 48-bit hardware address displays on
the screen with the %wdn line, the NIC is registered properly.

3. Change to multiuser mode by pressing CTRL + D.

4. Watch the boot sequence to see that IPX/SPX started properly. You
should see the following:

Starting IPX/SPX: npsd sapd nvtd xechod

Installing ORACLE SQL*Net SPX/IPX

The ORACLE SQL*Net SPX/IPX installation includes:   

■ Loading the SQL*Net SPX/IPX files into ORACLE_HOME

■ Running oracle.install as root

■ Running oracle.install as oracle
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Loading SQL*Net

Use the following procedure to load SQL*Net into ORACLE_HOME.

1. Log in to the SCO UNIX database server as the user, oracle.

2. Enter the appropriate password. For example:

oraclepswd

3. Insert the SQL*Net SPX/IPX V 1.0 diskette in the diskette drive.

4. Enter one of the following:

 ❑ To install from a 3 1/2-inch diskette in drive 0, enter

cpio -icBvd < /dev/fd0135ds18

 ❑ To install from a 5 1/4-inch diskette in drive 0, enter

cpio -icBvd < /dev/fd096ds15
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Installing as Root

After loading SQL*Net you must run oracle.install as root. The following
procedure provides instructions:   

1. Log in as root.

2. Change directories to $ORACLE_HOME/install by entering

cd /u/oracle/install

3. Run oracle.install by entering:

./oracle.install

4. Continue by pressing ENTER.

5. Accept the default $ORACLE_HOME directory (/u/oracle) by
pressing ENTER.

6. Accept the default owner of the ORACLE database (oracle) by pressing
ENTER.

7. Enter your operating system choice:

❏ For SCO UNIX, enter

1

❏ For SCO UNIX with MPX, enter

2

8. Accept the default (orac) as the ORACLE system identifier by pressing
ENTER.

9. When asked if you want to save install output, answer yes by entering

y

10. Accept the default name of the log file (/u/oracle/install/install.log) by
pressing ENTER.

11. When asked if you want to overwrite, answer yes by entering

y

12. Select Fresh Install from Scratch by entering

1
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13. Answer yes to "Run Root install" by entering

y

14. Accept the default local bin directory (/usr/lbin) by pressing ENTER.

15. Answer yes to "Install oracle man pages" by entering

y

16. At "Install SQL*Net TCP/IP," quit oracle.install by entering

q

Installing as Oracle

After running oracle.install as root, you must run oracle.install as the user,
oracle. To do so, complete the following steps:   

1. Log in as oracle.

2. Change directories to $ORACLE_HOME/install by entering

cd install

3. Run oracle.install to install the SPX package by entering

./oracle.install spx

4. Press ENTER to continue.

5. Accept the default $ORACLE_HOME directory (/u/oracle) by pressing
ENTER.

6. Accept the default owner of the ORACLE database (oracle) by
pressing ENTER.

7. Enter your operating system choice:

❏ For SCO UNIX, enter

1

❏ For SCO UNIX with MPX, enter

2
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8. Accept the default (orac) as the ORACLE system identifier by pressing
ENTER.

9. When asked if you want to save install output, answer yes by entering

y

10. Accept the default name of the logfile (/u/oracle/install/install.log) by
pressing ENTER.

11. When asked if you want to overwrite, answer yes by entering

y

12. Select Fresh Install from Scratch by entering

1

13. Answer no to "Relink ORACLE executables?" by entering

n

14. Answer yes to "Bring down database to add SQL*Net drivers"
by entering

y

NOTE:  At this point the ORACLE executables are relinked (regardless of the
previous questions).

15. To complete the SQL*Net SPX/IPX installation, log out and log back in
as oracle.
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Installing the Windows Workstation
The following table lists the configuration files altered during the installation
procedures:     

Table 2-3
Altered Windows Workstation

Configuration Files

Procedure File

SPX/IPX configuration c:\autoexec.bat

ORACLE configuration $ORACLE_HOME\config.ora
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The procedures for installing the Windows workstation include:

■ Installing SCO IPX/SPX DOS Component

■ Validating the network connection

■ Installing SQL*Net SPX/IPX

■ Configuring SQL*Net SPX/IPX

■ Validating the database connection

■ Installing PowerBuilder

■ Validating the PowerBuilder connection

■ Installing Forest & Trees

■ Validating the Forest & Trees connection

The following sections describe these procedures.

Installing SCO IPX/SPX DOS Component

To install SCO IPX/SPX DOS Component on the Windows workstation,
complete the following steps:  

1. Insert the DOS Component Disk in drive A.

2. Copy nvt.exe to the hard disk by entering the following command at
the system prompt:

copy a:nvt.exe c:\

Validating the Network Connection

Use the following procedure to validate the network connection:  

1. Boot the SCO UNIX database server in multiuser mode.

2. From the Windows workstation, start nvt.exe by entering

nvt
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3. To validate the IPX/SPX connection from the Windows workstation,
press ALT + T.

 If a popup window appears, IPX/SPX is loaded. If UNXSERV displays
in that window, the network (IPX/SPX) connection is working.

4. To quit, press ESC.

Installing ORACLE SQL*Net
SPX/IPX for DOS

The procedures for installing SQL*Net SPX/IPX include:  

■ Installing the DOS Install diskette

■ Installing the DOS Required Support Files

■ Installing the DOS Utilities

■ Installing the SQL*Net SPX/IPX software

The following sections describe these procedures.

Installing the DOS Install Diskette

To install the DOS Install diskette, complete the following steps:   

1. Insert the DOS Install Disk diskette into the diskette drive of the
Windows workstation.

2. Enter the following command preceded by the drive designator.
For example:

a:orainst

3. At the prompt to continue, enter

c

4. When prompted for the drive from which you are installing, enter the
appropriate drive letter. For example:

a
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5. When prompted for the drive and path where you want to install
ORACLE, accept the default (c:\oracle6) by pressing ENTER.

6. When prompted for the drive from which you boot your computer,
accept the default (drive c) by pressing ENTER.

7. When asked if you want config.sys changed automatically, accept the
default (yes) by pressing ENTER.

8. When asked if you want autoexec.bat changed automatically, accept the
default (yes) by pressing ENTER.

9. Remove the diskette and reboot the Windows workstation.

10. Again insert the DOS Install diskette into the diskette drive.

11. From the MS-DOS system prompt, execute orainst by entering

orainst

12. At the prompt to continue, enter

c

13. When prompted for the drive from which you are installing, accept the
default (drive A) by pressing ENTER.

14. When prompted for the drive and path where you want to install
ORACLE, accept the default (c:\oracle6) by pressing ENTER.
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Installing the DOS Required Support Files

To install the DOS Required Support Files, complete the following steps:  

1. Insert the DOS Required Support Files diskette into the diskette drive.

2. Select Install Product by pressing ENTER.

3. At the prompt to continue, enter

c

4. Select compaq and press ENTER.

5. Select the machine type (or a machine type that has the same
processor).

6. Confirm the machine type, by pressing ENTER.

7. Return to the Installation main menu, by pressing ENTER.
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Installing the DOS Utilities

To install the DOS Utilities, complete the following steps:  

1. Insert the DOS Utilities Disk 1 diskette into the diskette drive.

2. Select Install Product by pressing ENTER.

3. At the prompt to continue, enter

c

4. Select Protected Mode Only by pressing ENTER.

5. At the prompt to continue, enter

c

6. Replace the DOS Utilities Disk 1 diskette with the DOS Utilities
Disk 2 diskette.

7. At the prompt to continue, enter

c

8. Replace the DOS Utilities Disk 2 diskette with the DOS Utilities
Disk 3 diskette.

9. At the prompt to continue, enter

c

Install SQL*Net SPX/IPX for DOS

To install SQL*Net SPX/IPX for DOS, complete the following steps:   

1. Insert the SQL*Net SPX diskette into the diskette drive.

2. Select Install Product by pressing ENTER.

3. At the prompt to continue, enter

c

4. When complete, exit by pressing F10.
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Configuring SQL*Net SPX/IPX for DOS

Configuring SQL*Net involves editing the config.ora and autoexec.bat files.
The following sections provide instructions for editing those files.    

!
IMPORTANT:  After editing the files, reboot the computer for the
changes to take effect.

Editing CONFIG.ORA

Using the editor of your choice, add the following lines to the
config.ora file:

local=x:hostname:oracle_sid

For example:

x:unxserv:orac

!
IMPORTANT:  Be sure to enter this first line with all lower case
letters.

dynamic_memory=1000

NOTE:  This entry reserves 1 megabyte of system memory for ORACLE products
and leaves the remainder for Microsoft Windows to manage.

When finished, config.ora should contain the following lines:

local=x:unxserv:orac
dynamic_memory=1000
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Editing AUTOEXEC.BAT

Using the editor of your choice, add the following lines to the
autoexec.bat file:

c:\oracle6\bin\sqlpme.exe
c:\oracle6\bin\sqlspx.exe

These lines add the SQL*Net Protected Memory Manager and SQL*Net
SPX/IPX for DOS. When finished, autoexec.bat should contain the following
lines:

@echo off
prompt $p $g
break on
path c:\oracle6\pbin;c:\oracle6\bin;c:\windows;c:\dos
set config=c:\oracle6\config.ora
set temp=c:\windows\temp
c:\ipx.com
c:\netx.com
c:\oracle6\bin\sqlpme.exe
c:\oracle6\bin\sqlspx.exe

Verifying CONFIG.SYS

Verify that the config.sys file contains the following lines. If not, use the
editor of your choice and modify the file.   

device=c:\windows\himem.sys
files=40
buffers=30
stacks=9,256
break=on
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Validating the Database Connection

Validating the database connection involves starting ORACLE on
the UNIX database server and connecting with the sqldba utility
from the Windows workstation. The following section provides the validating
procedures using the demonstration database provided by ORACLE. For this
sample database, the ORACLE ID is scott and the password for accessing the
database is tiger.  

UNIX Database Server

To begin validation, complete the following steps from the UNIX
database server:

1. Boot the UNIX database server in multiuser mode.

2. Log in as the user, oracle, by entering the user name:

oracle

3. Enter the password. For example:

oraclepswd

4. Start the RDBMS by entering

sqldba startup
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Windows Workstation

To continue with the validation, complete the following steps from the
Windows workstation:

1. Start the Windows workstation, but do not start Microsoft Windows.

2. At the system prompt, enter

sqldba

3. Once connected, enter the ORACLE ID:

scott

4. Enter the password

tiger

 If the connection is successful, the following displays on the screen:

connected

5. Enter the following SQL statement

select table_name from user_tables;

 The following displays on the screen:

BONUS
DEPT
DUMMY
EMP
IAPXTB
SALGRADE
rows selected

6. Quit the sqldba utility by entering

exit
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Installing PowerBuilder

The steps for installing PowerBuilder include:   

■ Installing the PowerBuilder software

■ Creating a PowerBuilder icon

■ Installing the ORACLE Interface

If you are not installing Forest and Trees, you must also download a file
named ora6win.dll from the PowerSoft Bulletin Board. See the "Downloading
ORA6WIN.DLL" section later in this chapter for instructions.

Installing the PowerBuilder Software

To install the PowerBuilder software, complete the following steps:

1. Insert the Disk 1 diskette into the diskette drive.

2. Start Microsoft Windows from the system prompt by entering

win

3. From the menu bar, select File  Run.

4. In the Command Line field, enter the following command preceded by
the drive designator for the diskette drive containing the Disk 1
diskette. For example:

a:setup

5. For the destination directory, select the default (c:\pb) by
pressing ENTER.

6. When prompted to create the directory, answer yes by
pressing ENTER.

7. At the "Space Available" prompt, continue by pressing ENTER.
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8. When prompted, replace the Disk 1 diskette with the Disk 2 diskette
and press ENTER.

9. When prompted, replace the Disk 2 diskette with the Disk 3 diskette
and press ENTER.

Creating a PowerBuilder Icon

To create a PowerBuilder Icon, complete the following steps:   

1. Open the group where you want the PowerBuilder icon.

2. From the menu bar, select File → New.

3. From the dialog box, select Item → OK.

4. For the description, enter

PowerBuilder

5. In the Command Line field, enter

c:\pb\pb020.exe

6. Press ENTER to select OK.

Installing the ORACLE Interface

To install the ORACLE interface, complete the following steps:  

1. Insert the ORACLE Interface Disk diskette into the diskette drive.

2. From the menu bar, select File → Run.

3. In the Command Line field, enter the following command preceded by
the drive designator. For example:

a:setup
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Downloading ORA6WIN.DLL

If you are installing Forest & Trees, you can skip this section as the
ora6win.dll file comes with that package. If you are not installing Forest &
Trees, you must acquire the ora6win.dll file and copy it to the hard disk. The
following steps outline that procedure:

1. Using the connection software of your choice, connect to the
PowerSoft Bulletin Board. The phone number is (617) 229-9735. The
connection parameters are 2400 baud, 8 bit, no parity, 1 stop bit.

2. Download oracle.zip.

3. Download pkunzip.exe if necessary. You use this program to extract
ora6win.dll from the compressed oracle.zip file.

4. Extract ora6win.dll from oracle.zip by entering

pkunzip oracle.zip

5. Copy the file to c:\oracle6\bin by entering

copy a:\ora6win.dll  c:\oracle6\bin

Validating the PowerBuilder Connection

The following sections provide procedures for validating the PowerBuilder
and ORACLE database connection. These procedures include:   

■ Starting PowerBuilder

■ Creating a Unique Index on the EMP database table

■ Viewing EMP table data

■ Closing PowerBuilder
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Starting PowerBuilder

To start PowerBuilder and set the ORACLE parameters, complete the
following steps:   

!
IMPORTANT:  You must log in as system/manager for only the first
connection using PowerBuilder. This procedure allows PowerBuilder
to create its ORACLE system tables. Later, log in as scott/tiger.

1. To start Microsoft Windows, enter the following from the
system prompt:

win

2. Start the PowerBuilder Power Panel by double-clicking on the
PowerBuilder icon.

3. From the Power Panel, double-click on the Preferences icon.

4. From the Preference window, double-click on the Database icon.

5. Enter the parameters according to the following table:   

Table 2-4
PowerBuilder Parameters for ORACLE

Parameter Selection/entry

Vendor Oracle

DBMS Oracle

LogId system

LogPassword manager

ServerName @x:unxserv:orac

NOTE: You do not need to set the rest of the parameters for ORACLE.

6. Select OK to return to the Power Panel.
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7. From the Power Panel, double-click on the Database Painter icon.

 It takes a few moments to establish the connection. During this
first connection PowerBuilder builds the PowerBuilder/ORACLE
system tables.

 To see the icon names on the left side of the Database Painter screen,
hold the left mouse button down and drag the mouse pointer over the
icons. The names appear under each icon.

8. From the menu bar, select File → Change Login.

9. In the "User Name:" field, enter

scott

10. In the "Enter Password:" field, enter

tiger

11. Select OK.

Creating a Unique Index on the EMP Table

To create an index on the EMP table, complete the following steps:   

1. Select emp → Open. The EMP table opens.

2. Maximize the table by clicking on the maximize arrow.

3. Click on the key icon (Index) on the left column.

4. For the "Enter Create Index Name:" field, enter

empno

6. Click on empno in the column list at the lower left.

7. To finish, select OK.
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Viewing the EMP Data

To view data on the EMP table, complete the following steps:

1. Click on the Tabular Data Window icon. (The Tabular Data Window
icon looks like two slender rectangles and is located in the middle of
the left column.)

2. Select Retrieve to view the data.

Closing PowerBuilder

To close PowerBuilder, complete the following steps:

1. Close the Tabular Data Window by clicking on Close.

2. Close the Database Painter by selecting File → Close.

3. Exit PowerBuilder by selecting File → Exit PowerBuilder.

Installing Forest & Trees

To Install Forest and Trees, complete the following steps:   

1. Start Microsoft Windows.

2. Insert the Disk 1 of 3 diskette into the diskette drive.

3. From the menu bar, select File → Run.

4. In the "Command Line:" field, enter the following commanded
preceded by the drive designator. For example:

a:install

5. Select the default directory (c:\ftw) by pressing ENTER.

6. In the "User:" field, enter the user name for this workstation.

7. In the "Company:" field, enter your company name.

8. In the "Serial Number:" field, enter the serial number that came
with this product.
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9. Under "Client Server Providers," select: Oracle.

10. Use the space bar to deselect SQL Server, SQL Base, and
NetWare SQL.

11. At the prompt to continue, press ENTER.

12. Replace the Disk 1 of 3 diskette with the Disk 2 of 3 diskette.

13. To continue, press ENTER.

14. Replace the Disk 2 of 3 diskette with the Disk 3 of 3 diskette.

15. To continue, press ENTER.

16. When complete, select OK by pressing ENTER.

Validating the Forest & Trees Connection

To validate the Forest & Trees connection, complete the following steps:   

1. Start Forest & Trees from Windows by double-clicking on the
FTW icon.

2. From the menu bar, select View → New.

3. In the "Name:" field enter

test

4. In the "Provider:" field, enter

oracle

5. For "Data Type:" select Automatic.

6. Select OK.

7. Double-click on the Database icon.

8. For the "Database Name:" field, enter

x:unxserv:orac

9. For the "Username:" field, enter

scott
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10. For the "Password:" field, enter

tiger

11. Select OK.

12. Double-click on the Query icon.

13. Click on Query Assist.

14. At the "Table:" field, click on the DOWN arrow.

15. Select SCOTT.EMP.

16. In the "Columns:" field, select EMPNO → Select → Add.

17. Select ENAME → Select → Add.

18. Select JOB → Select → Add.

19. Select OK.

20. Click on Test Query: Rows display on the screen.

21. To exit Forest & Trees, select Exit → Query Results.

22. At "Exit Edit Query:" select CANCEL.

23. From the menu bar, select File → Exit.

24. At "Save Changes:" select NO.
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Operating the SPX/IPX Platform
The following sections provide instructions for starting and stopping the
SPX/IPX Platform.

Starting the SCO UNIX Database Server

To start the SCO UNIX database server, complete the following steps:   

1. Boot the system in multiuser mode.

2. To log in as the user oracle, enter

oracle

3. Then enter the password. For example:

oraclepswd

4. Start SQL*Net SPX/IPX for UNIX by entering

spxctl start

5. Start the ORACLE administrator utility, sqldba, by entering

sqldba

6. Start the ORACLE RDBMS by entering

startup

7. To exit the sqldba utility, enter

exit
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Starting the NetWare Server

To start the NetWare server, complete the following steps:   

1. Boot the NetWare server.

2. Change directories to the directory where you copied your installation
files. For example:

cd \netware

3. Then enter

server

Starting the Windows Workstation

To start the workstation, complete the following steps:   

1. Boot the workstation.

2. Start Microsoft Windows by entering

win

Stopping the SCO UNIX Database Server

To stop the SCO UNIX database server, complete the following steps:   

1. As the user, oracle, start the ORACLE administrator utility, sqldba by
entering

sqldba

2. Stop the ORACLE RDBMS by entering

shutdown

3. Exit the sqldba utility by entering

exit
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4. Log in as root by entering

root

5. Enter the root password. For example:

rootpswd

6. Stop the SCO UNIX server by entering

shutdown -g0 -y

Stopping The NetWare Server

To stop the NetWare server, complete the following steps:   

1. From the server console, enter

down

2. Exit by entering

exit

Stopping the Windows Workstation

To exit from Microsoft Windows select File → Exit from the menu bar.
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Chapter 3
TCP/IP Platform

Using the information in this chapter you can reproduce the TCP/IP model. The
following sections describe the TCP/IP Platform and provide installation
instructions.

Platform Components
The following figure illustrates the entire TCP/IP Platform:

Figure 3-1.  TCP/IP Platform
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The following table lists the components you will install on the NetWare
server, the Windows workstation, and the UNIX database server using this
TechNote:   

Table 1-1
Software Components to Install

NetWare Server MS-DOS Workstation SCO UNIX Server

none SQL*Net TCP/IP 1.1 none

LAN WorkPlace for DOS 4.01

PowerBuilder 2.0

Forest & Trees 2.0c

Platform Concepts
It is important to understand some of the basic concepts used in this platform.
The following sections explain TCP/IP network addressing, operating system
transparency, and multiple protocol stacks in
Windows workstations.

TCP/IP Network Addressing

TCP/IP network addressing depends on three numbers: hardware network
interface card (NIC) addresses, internet (network and machine) addresses, and
port numbers (internal application addresses).

Hardware addresses are usually determined by the manufacturer and are read
automatically by the NIC driver.

The network administrator assigns internet addresses. The local number is
mapped to the NIC at boot time. Usually, a translation table of hostnames and
their respective internet addresses used to communicate with other UNIX
hosts are maintained in a file called hosts.
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Each machine is configured with a unique internet address. The internet
address has four octets (8-bit bytes) identified by numbers (for example:
131.168.147.100). This internet address consists of two parts: the network
part and the machine part. These addresses are used in network transmissions
to route packets across multiple network segments and finally to the
destination machines.

Port numbers are used in establishing a communications session between a
client and a server. In the case of ORACLE, the port number that clients call
in on is usually 1525. Once the initial connection is established, a new port
number is assigned for the duration of the session. The initial port number is
usually defined in a file called services.

Operating System Transparency and ORACLE
Connect Strings

To establish a session with an ORACLE database server, the client must send
a connect string to the server along with an ORACLE login ID and
an ORACLE password. The connect string usually contains three fields
of information: the protocol abbreviation, the server name, and the database
identifier. For example, to log in via TCP/IP to a UNIX server named unxserv
where an ORACLE database identified as orac is running, you would use the
following connect string:     

t:unxserv:orac

The only change needed to log in to the same server and database via
SPX/IPX is to replace the letter "t" in the connect string with the letter "x."

x:unxserv:orac

The connect string is nearly identical for connecting to a NetWare and
ORACLE server. For example:

t:nwserv:orasrv
x:orasrv

The result is that the end user need not know whether the data source is an
ORACLE server running on UNIX or running on NetWare.
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Multiple Protocol Stacks in
Windows Workstations

The TCP/IP Platform is a "dual-protocol" platform. Dual protocol means that
two protocol stacks are used with a single NIC. In this platform, SPX/IPX is
used for NetWare services and TCP/IP is used for UNIX services as well as
ORACLE database services. The three most common specifications for
implementing dual protocol stacks in an MS-DOS workstation are:

■ Open Data Link Interface (ODI) from Novell

■ Network Driver Interface Specification (NDIS) from Microsoft

■ Packet Driver Interface (PDI) from Clarkson University and FTP

Each of these technologies employs a protocol manager that directs incoming
packets to the correct protocol stack (in this case, either SPX/IPX or TCP/IP).
LAN WorkPlace for DOS by Novell supplies both protocol stacks as well as
Microsoft Windows-based applications for file transfer and for terminal
emulation to communicate with UNIX hosts.

Pre-Installation Assumptions
This TechNote assumes two existing conditions:   

■ A NetWare server and Windows workstation are physically connected
to an Ethernet network.

■ A COMPAQ SYSTEMPRO running SCO UNIX and ORACLE as a
database server is physically connected on the same network, and is
operational with TCP/IP support.
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The following figure illustrates the configuration you should have in place
before beginning this installation:   

Figure 3-2.  Pre-installed Software

If you have not completed this type of installation, you can refer to the
Compaq and Novell Integration ToolKit and the Compaq and SCO
Client-Server ToolKit, both published by Compaq Computer Corporation.

NOTE:  Both TCP/IP Version 1.1.3 and Version 1.2 from SCO were tested
successfully in this environment.
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SCO UNIX Database Server

The following list describes the database server components you should have
installed before you begin:   

■ COMPAQ SYSTEMPRO installed as a server

■ Appropriate Ethernet network interface card (NIC) and cable

■ SCO UNIX System V/386 Release 3.2 Version 4

■ SCO UNIX Maintenance Supplement Version 4.0.1d
(if using SCO TCP/IP Release 1.2)

■ SCO LLI Drivers Version 3.0 or later

■ SCO TCP/IP Release 1.1.3 or 1.2

■ SCO UNIX Development System Release 3.2 Version 4

■ SCO TCP/IP Development System Release 1.1.3 or 1.2
(This version must match the SCO TCP/IP version used.)

■ COMPAQ Supplement for SCO UNIX
(COMPAQ EFS for SCO UNIX Version 1.4)

■ ORACLE Relational Database Management System (RDBMS) Version
6.0.33 (includes SQL*Net TCP/IP for UNIX)

In addition, be sure to have a working TCP/IP connection.

NetWare Server

The following list describes the NetWare server components you should have
installed before you begin:   

■ COMPAQ 386 or 486-based server (minimum)

■ NE2000 Ethernet (or other suitable NIC)

■ NetWare v3.11 from Compaq
(includes SPX/IPX)



.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
3-7

SCO UNIX Database Servers in Novell Networks

The following display is an example of the assumed autoexec.ncf file for the
NetWare server:   

file server name NWFS1
ipx internal net 12A34B

bind IPX to ipxlan net=101

Windows Workstation

The following list describes the workstation components you should have
installed before you begin:   

■ COMPAQ 386sx-based PC (minimum)

■ NE2000 Ethernet NIC (or other suitable NIC)

■ MS-DOS 5.0, as published by Compaq, located in the directory, c:\dos

■ Microsoft Windows 3.1 located in the directory, c:\windows

The following displays are examples of the assumed autoexec.bat and
config.sys files for the Windows workstation:

autoexec.bat   

c:\windows\smartdrv.exe
prompt $p $g
path c:\windows;c:\dos
temp=c:\windows\temp
c:\ipx.com
c:\netx.com

config.sys  

device=c:\windows\himem.sys
files=20
buffers=30
stacks=9,256
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Installing the
Windows Workstation

The following table lists the configuration files altered during the installation
procedures:     

Table 1-2
Altered Windows Workstation Configuration Files

Procedure File

SPX/IPX Configuration c:\autoexec.bat

TCP/IP Configuration c:\autoexec.bat
c:\net.cfg
c:\xln\tcp\hosts
c:\xln\tcp\service

ORACLE Configuration $ORACLE_HOME\config.ora

The procedures for installing the Windows workstation include:

■ Installing the MS-DOS ODI drivers

■ Installing LAN WorkPlace for DOS

■ Installing SQL*Net TCP/IP for DOS

■ Configuring SQL*Net TCP/IP for DOS

■ Validating the database connection

■ Installing PowerBuilder

■ Validating the PowerBuilder connection

■ Installing Forest & Trees

■ Validating the Forest & Trees connection

The following sections describe these procedures.
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Installing the MS-DOS ODI Drivers

To install the MS-DOS ODI drivers that come with NetWare, complete the
following steps:  

1. Insert the DOS ODI Driver diskette into the diskette drive.

2. Copy the Link Support Layer protocol manager to the root directory
of drive C. For example, if the DOS ODI Driver diskette is in
drive A, enter:

copy a:\lsl.com c:\

3. Copy the MLID network interface driver to the root directory
of drive C. For example, if the DOS ODI Driver diskette is in
drive A, enter:

copy a:\ne2000.com c:\

4. Change to drive C by entering

c:

5. Make a directory called odi for the nw_shell program by entering

md c:\odi

6. Change to the odi directory by entering

cd c:\odi

7. Copy nw_shell to the new directory. For example, if the DOS ODI
Driver diskette is in drive A, enter:

copy a:\nw_shell.exe c:\odi\nw_shell.exe

8. Expand nw_shell.exe by executing it. Enter

nw_shell.exe

9. Copy the IPX protocol stack to the root directory of drive C
by entering

copy c:\odi\ipxodi.com c:\
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10. Copy the NetWare redirector to the root directory of drive C
by entering

copy c:\odi\netx.com c:\

11. To configure the ODI drivers, use the editor of your choice and add the
following lines to the autoexec.bat file:

c:\lsl.com
c:\ne2000.com
c:\ipxodi.com
c:\netx.com

12. If the default settings on the network interface card were changed,
create net.cfg as instructed in the ODI for DOS User's Guide. (See the
"Viewing Configuration File Changes" section later in this chapter for
an example file.)

13. With a NetWare server running, reboot the computer to test the
installation. If successful, the workstation connects to the server.

Installing LAN WorkPlace for DOS

Installation procedures for LAN WorkPlace for DOS include:

■ Installing the LAN WorkPlace software

■ Viewing configuration file changes

■ Validating the SPX/IPX and TCP/IP protocol stacks

■ Configuring LAN WorkPlace for DOS

■ Validating the LAN WorkPlace for DOS installation

The following sections describe those procedures.
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Installing LAN WorkPlace

To install LAN WorkPlace for DOS, complete the following steps:   

1. From drive C, enter the following command preceded by the designator
of the drive from which you will install. For example:

a:install

2. Select Install Drive.

3. To select the default drive (C), press ENTER.

4. At the "Do you wish to install the LAN WorkPlace Windows
Applications?" prompt, respond yes by pressing ENTER.

5. At the "Will a RARP server provide your IP address?" prompt, respond
no by pressing ENTER.

6. Enter the IP address you obtained from your network administrator.
For example:

132.147.160.21

7. At the "Is your network partitioned into subnets?" prompt, respond no
by pressing ENTER.

8. At the "Does your network have an IP router?" prompt, respond no by
pressing ENTER.

9. At the "Do you want to use the default TCP/IP configuration
parameters?" prompt, respond yes by pressing ENTER.
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10. At the "Does your network have a domain name server?" prompt,
respond no by pressing ENTER.

11. At the "Do you want to load RFC NetBIOS during system boot?"
prompt, respond no by pressing ENTER.

12. At the "Will you be using applications written for LAN WorkPlace for
DOS v3.5?" prompt, enter

yes

!
IMPORTANT:  Answering yes at this prompt is critical for
SQL*Net TCP/IP for DOS to function properly with the sqldba
utility.

13. When prompted, enter your user name. For example:

nw1

14. At the "Do you want your system files updated?" prompt, respond yes
by pressing ENTER.

15. Install the remaining disks as prompted.
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Viewing Configuration File Changes

The following file displays show how the configuration files changed after
installing LAN WorkPlace:

autoexec.bat - Added Lines  

set include=c:\xln\toolkit\include
set lib=c:\xln\toolkit\lib
c:\xln\bin40\tcpip
c:\xln\bin40\convert
c:\xln\bin40\telapi
set name=nw1
set excelan=c:\xln

config.sys   

device=c:\windows\himem.sys
files=40
buffers=30
stacks=9,256
break=on
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net.cfg - Significant Sections

Link Support
Buffers 8 1500
MemPool 4096

Link Driver NE2000
INT  #1 3
PORT #1 300

Protocol IPX 0 Ethernet_802.3

Protocol TCPIP

132.147.160.21

0.0.0.0

255.255.0.0
8
8
1

sions 4
8
0

nb_domain

Note that net.cfg was added to the root directory. Examine the section on the
NE2000 card. This section provides support for both 802.3 packets for
SPX/IPX and Ethernet II packets for TCP/IP communications. Also, TCP/IP
information is in the Protocol TCPIP section of this file.

!
IMPORTANT:  The address for the subnet mask (ip_netmask) must
match the subnet mask on the SCO UNIX database server.



.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
3-15

SCO UNIX Database Servers in Novell Networks

Validating the SPX/IPX and TCP/IP Connections

To validate the protocol stack installation, complete the following steps:       

1. Reboot the workstation.

2. Change to drive F by entering

f:

3. Log in to the NetWare server.

4. If the login is successful, SPX/IPX is working

5. Change to drive C by entering

c:

5. Use ping to test the TCP/IP connection by issuing the command with
the host (unxserv) IP address you obtained from your network
administrator. For example:

ping 132.147.160.1

6. Look at the first line after the command entry. If the network
connection is working properly, the message reads:

host responding time = xx ms

Configuring LAN WorkPlace for DOS

To configure LAN WorkPlace for DOS, complete the following steps:   

1. Start Microsoft Windows by entering the following at the system prompt:

win

2. Using the Windows accessory, Notepad, create a hosts file in c:\xln\tcp
with the following syntax:

ip address  hostname

 For example:

132.147.160.1 unxserv
132.147.160.2 nwserv
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3. Select Save As.

4. In the filename field enter

c:\xln\tcp\hosts.

 Be sure to include the period after "hosts" when using Notepad.

Validating LAN WorkPlace for DOS

The procedure for validating LAN WorkPlace for DOS includes:   

■ Starting File Express

■ Changing drives to the NetWare Server

■ Copying UNIX /etc/hosts to NetWare f:\hosts

■ Deleting f:\hosts

To validate LAN WorkPlace for DOS, complete the following steps:

1. Open the LAN WorkPlace for DOS Group.

2. Double click on the File Express Icon.

3. Enter the hostname and press TAB.

4. Enter

root

 and press TAB.

5. Enter the root password.

6. In the MS-DOS window, click on C:

7. Enter

f:\

8. In the UNIX window, double click on etc.
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9. Scroll to the right until hosts is visible.

10. Click on hosts to select it.

11. Click on Copy at the right side of the screen.

 Note that hosts is in the root directory of the NetWare server.

12. In the NetWare window, click on hosts.

13. Click on Delete.

14. Click on yes to confirm.

15. Exit LAN WorkPlace for DOS.

16. Exit Windows.

Installing SQL*Net TCP/IP for DOS

The procedures for installing SQL*Net TCP/IP include:  

■ Installing the initial installation files

■ Installing the Required Support files

■ Installing the DOS Utilities

■ Installing SQL*Net TCP/IP
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Installing the DOS Install Diskette

To install the DOS Install Disk diskette, complete the following steps:   

1. Insert the DOS Install Disk diskette into the diskette drive of the
Windows workstation.

2. Enter the following command preceded by the drive designator.
For example:

a:orainst

3. At the prompt to continue, enter

c

4. When prompted for the drive from which you are installing, enter the
appropriate drive letter. For example:

a

5. When prompted for the drive and path where you want to install
ORACLE, accept the default (c:\oracle6) by pressing ENTER.

6. When prompted for the drive from which you boot your computer,
accept the default (drive c) by pressing ENTER.

7. When asked if you want config.sys changed automatically, accept the
default (yes) by pressing ENTER.

8. When asked if you want autoexec.bat changed automatically, accept
the default (yes) by pressing ENTER.

9. Remove the diskette and reboot the Windows workstation.

10. Again insert the DOS Install diskette into the diskette drive.

11. From the MS-DOS system prompt, execute orainst by entering

orainst
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12. At the prompt to continue, enter

c

13. When prompted for the drive from which you are installing, accept the
default (drive A) by pressing ENTER.

14. When prompted for the drive and path where you want to install
ORACLE, accept the default (c:\oracle6) by pressing ENTER.

NOTE:  There are two changes to autoexec.bat:

❏ Path includes c:\oracle6\pbin; c:\oracle6\bin

❏ Variable config=c:\oracle6\config.ora

There are no changes to config.sys.

Installing the DOS Required Support Files

To install the DOS Required Support Files, complete the following steps:  

1. Insert the DOS Required Support Files diskette into the diskette drive.

2. Select Install Product by pressing ENTER.

3. At the prompt to continue, enter

c

4. Select compaq and press ENTER.

5. Select the machine type (or a machine type that has the same
processor).

6. Confirm the machine type, by pressing ENTER.

7. Return to the Installation main menu, by pressing ENTER.
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Installing the DOS Utilities

To install the DOS Utilities, complete the following steps:  

1. Insert the DOS Utilities Disk 1 diskette into the diskette drive.

2. Select Install Product by pressing ENTER.

3. At the prompt to continue, enter

c

4. Select Protected Mode Only by pressing ENTER.

5. At the prompt to continue, enter

c

6. Replace the DOS Utilities Disk 1 diskette with the DOS Utilities
Disk 2 diskette.

7. At the prompt to continue, enter

c

8. Replace the DOS Utilities Disk 2 diskette with the DOS Utilities
Disk 3 diskette.

9. At the prompt to continue, enter

c
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Installing SQL*Net TCP/IP

To install SQL*Net TCP/IP, complete the following steps:   

1. Insert the SQL*Net TCP/IP diskette into the diskette drive.

2. To continue the installation, enter

c

3. Select Install Product by pressing ENTER.

4. When prompted for the vendor from which you purchased your
TCP/IP, select Excelan.

5. When prompted for the path and filename of your TCP/IP hosts file,
accept the default (c:\xln\tcp\hosts) by pressing ENTER.

6. When prompted for the path and filename of your TCP/IP services file,
accept the default (c:\xln\tcp\services) by pressing ENTER.

7. When asked if you wish to update c:\oracle6\config.ora automatically,
accept the default (yes) by pressing ENTER.

8. At the prompt to continue, enter

c

9. Quit the installation by selecting Exit install.

NOTE:  You do not have to install LOADER files which are used with Lotus 123
and dBASE III Plus.
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Configuring SQL*Net TCP/IP for DOS

Configuring SQL*Net involves editing the config.ora, services, and
autoexec.bat files. The following sections provide instructions for editing
those files.

Editing CONFIG.ORA

Using the editor of your choice, add the following lines to the
config.ora file:

local=t:hostname:oracle_sid

For example:

t:unxserv:orac

!
IMPORTANT:  Be sure to enter this first line with all lower case
letters.

dynamic_memory=1000

NOTE:  This entry reserves 1 megabyte of system memory for ORACLE products
and leaves the remainder for Microsoft Windows to manage.

When finished, config.ora should contain the following lines:

local=t:unxserv:orac
dynamic_memory=1000
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Editing SERVICES in C:\XLN\TCP

Using the editor of your choice, add the following lines to the services file:

orasrv1525/tcp

!
IMPORTANT:  If the services file is not in c:\xln\tcp, copy it from
c:\xln\sample.

Editing AUTOEXEC.BAT

Using the editor of your choice, add the following lines to the
autoexec.bat file:

c:\oracle6\bin\sqlpme.exe
c:\oracle6\bin\sqltcp.exe

These lines add the SQL*Net Protected Memory Manager and SQL*Net TCP/IP
for DOS. When finished, autoexec.bat should contain the following lines:

@echo off
prompt $p $g
break on
path c:\oracle6\pbin;c:\oracle6\bin;c:\windows;c:\dos;c:\xln\bin40

set config=c:\oracle6\config.ora
set include=c:\xln\toolkit\include
set lib=c:\xln\toolkit\lib
set name=nw1
set excelan=c:\xln

c:\config\tcp\lsl.com
c:\config\tcp\ne2000.com
c:\config\tcp\ipxodi.com
c:\config\tcp\netx.com

c:\xln\bin40\tcpip
c:\xln\bin40\convert
c:\xln\bin40\telapi

c:\oratcp\bin\sqlpme.exe
c:\oratcp\bin\sqltcp.exe
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Verifying CONFIG.SYS

Verify that the config.sys file contains the following lines. If not, use the
editor of your choice and modify the file.

device=c:\windows\himem.sys
files=40
buffers=30
stacks=9,256
break=on

Verifying NET.CFG

Verify that the net.cfg file contains the following lines. If not, use the editor of
your choice and modify the file.

Link Support
Buffers 8 1500
MemPool 4096

Link Driver NE2000
INT  #1 3
PORT #1 300

Protocol IPX 0 Ethernet_802.3

Protocol TCPIP

132.147.160.21

0.0.0.0

255.255.0.0
8
8
1
4
8
0

nb_domain
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Validating the Database Connection

Validating the database connection involves starting ORACLE on
the UNIX database server and connecting with the sqldba utility
from the Windows workstation. The following section provides the validating
procedures using the demonstration database provided by ORACLE. For this
sample database, the ORACLE ID is scott and the password for accessing the
database is tiger.  

UNIX Database Server

To begin validation, complete the following steps from the UNIX
database server:

1. Boot the UNIX database server in multiuser mode.

2. Log in as the user, oracle, by entering the user name:

oracle

3. Enter the password, for example:

oraclepswd

4. Start the RDBMS by entering

sqldba startup
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Windows Workstation

To continue with the validation, complete the following steps from the
Windows workstation:

1. Start the Windows workstation, but do not start Microsoft Windows.

2. At the system prompt, enter

sqldba

3. Once connected, enter the ORACLE ID:

scott

4. Enter the password:

tiger

If the connection is successful, the following displays on the screen:

connected

5. Enter the following SQL statement:

select table_name from user_tables;

 The following displays on the screen:

BONUS
DEPT
DUMMY
EMP
IAPXTB
SALGRADE
rows selected

6. Quit the sqldba utility by entering

exit
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Installing PowerBuilder

The steps for installing PowerBuilder include:   

■ Installing the PowerBuilder software

■ Creating a PowerBuilder icon

■ Installing the ORACLE Interface

If you are not installing Forest and Trees, you must also download a file
named ora6win.dll from the PowerSoft Bulletin Board. See the Downloading
ORA6WIN.DLL section later in this chapter for instructions.

Installing the PowerBuilder Software

To install the PowerBuilder software, complete the following steps:

1. Insert the Disk 1 diskette into the diskette drive.

2. Start Microsoft Windows.

3. From the menu bar, select File → Run.

4. In the Command Line field, enter the following command preceded by
the drive designator. For example:

a:setup

5. For the destination directory, select the default (c:\pb) by
pressing ENTER.

6. When prompted to create the directory, answer yes by
pressing ENTER.

7. At the "Space Available" prompt, continue by pressing ENTER.

8. When prompted, replace the Disk 1 diskette with the Disk 2 diskette
and press ENTER when finished.

9. When prompted, replace the Disk 2 diskette with the Disk 3 diskette
and press ENTER when finished.
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Creating a PowerBuilder Icon

To create a PowerBuilder Icon, complete the following steps:   

1. Open the group where you want the PowerBuilder icon.

2. From the menu bar, select File → New.

3. From the dialog box, select Item → OK.

4. For the description, enter

PowerBuilder

5. In the Command Line field, enter

c:\pb\pb020.exe

6. Press ENTER to select OK.

Installing the ORACLE Interface

To install the ORACLE interface, complete the following steps:

1. Insert the ORACLE Interface Disk diskette into the diskette drive.

2. From the menu bar, select File → Run.

3. In the Command Line field, enter the following command preceded by
the drive designator. For example:

a:setup
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Downloading ORA6WIN.DLL

If you are installing Forest & Trees, you can skip this section as the
ora6win.dll file comes with that package. If you are not installing Forest &
Trees, you must acquire the ora6win.dll file and copy it to the hard disk. The
following steps outline that procedure:

1. Using the connection software of your choice, connect to the
PowerSoft Bulletin Board. The phone number is (617) 229-9735. The
connection parameters are 2400 baud, 8 bit, no parity, 1 stop bit.

2. Download oracle.zip.

3. Download pkunzip.exe if necessary. You use this program to extract
ora6win.dll from the compressed oracle.zip file.

4. Extract ora6win.dll from oracle.zip by entering

pkunzip oracle.zip

5. Copy the file to c:\oracle6\bin by entering

copy a:\ora6win.dll  c:\oracle6\bin

Validating the PowerBuilder Connection

The following sections provide procedures for validating the PowerBuilder
and ORACLE database connection. These procedures include:   

■ Starting PowerBuilder

■ Creating a Unique Index on the EMP database table.

■ Viewing EMP table data

■ Closing PowerBuilder
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Starting PowerBuilder

To start PowerBuilder and set the ORACLE parameters, complete the
following steps:   

!
IMPORTANT:  You must log in as system/manager for only the first
connection using PowerBuilder. This procedure allows PowerBuilder
to create its ORACLE system tables. Later, log in as scott/tiger.

1. To start Microsoft Windows, enter the following from the
system prompt:

win

2. Start the PowerBuilder Power Panel by double-clicking on the
PowerBuilder icon.

3. From the Power Panel, double-click on the Preferences icon.

4. From the Preference window, double-click on the Database icon.

5. Enter the parameters according to the following table:

Table 3-3
PowerBuilder Parameters for ORACLE

Parameter Selection/entry

Vendor Oracle

DBMS Oracle

LogId system

LogPassword manager

ServerName @t:unxserv:orac

NOTE: You do not need to set the rest of the parameters for ORACLE.

6. Select OK to return to the Power Panel.
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7. From the Power Panel, double-click on the Database Painter icon.

 It takes a few moments to establish the connection. During this
first connection PowerBuilder builds the PowerBuilder/ORACLE
system tables.

 To see the names of the icons on the left side of the screen in the
Database Painter, hold the left mouse button down and drag the mouse
pointer over the icons. The names appear under each icon.

8. From the menu bar, select File → Change Login.

9. In the "User Name:" field, enter

scott

10. In the "Enter Password:" field, enter

tiger

11. Select OK.

Creating a Unique Index on the EMP Table

To create an index on the EMP table, complete the following steps:

1. Select emp → Open. The EMP table opens.

2. Maximize the table by clicking on the maximize arrow.

3. Click on the key icon (Index) on the left column.

4. For the "Enter Create Index Name:" field, enter

empno

6. Click on empno in the column list at the lower left.

7. To finish, select OK.
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Viewing the EMP Data

To view data on the EMP table, complete the following steps:

1. Click on the Tabular Data Window icon. (The Tabular Data Window
icon looks like two slender rectangles and is located in the middle of
the left column.)

2. Select Retrieve to view the data.

Closing PowerBuilder

To close PowerBuilder, complete the following steps:

1. Close the Tabular Data Window by clicking on Close.

2. Close Database Painter by selecting File → Close.

3. Exit PowerBuilder by selecting File → Exit PowerBuilder.

Installing Forest & Trees

To Install Forest and Trees, complete the following steps:   

1. Start Microsoft Windows.

2. Insert the Disk 1 of 3 diskette into the diskette drive.

3. From the menu bar, select File → Run.

4. In the "Command Line:" field, enter the following command preceded
by the drive designator. For example:

a:install

5. Select the default directory (c:\ftw) by pressing ENTER.

6. In the "User:" field, enter the user name for this workstation.
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7. In the "Company:" field, enter your company name.

8. In the "Serial Number:" field, enter the serial number that came
with this product.

9. Under "Client Server Providers," select: Oracle.

10. Use the space bar to deselect SQL Server, SQL Base, and
NetWare SQL.

11. At the prompt to continue, press ENTER.

12. Replace the Disk 1 of 3 diskette with the Disk 2 of 3 diskette.

13. To continue, press ENTER.

14. Replace the Disk 2 of 3 diskette with the Disk 3 of 3 diskette.

15. To continue, press ENTER.

16. When complete, select OK by pressing ENTER.

Validating the Forest & Trees Connection

To validate the Forest & Trees connection, complete the following steps:   

1. Start Forest & Trees from Windows by double-clicking on the
FTW icon.

2. From the menu bar, select View → New.

3. In the "Name:" field, enter

test

4. In the "Provider:" field, enter

oracle

5. For "Data Type:" select Automatic.

6. Select OK.
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7. Double-click on the Database icon.

8. For the "Database Name:" field, enter

t:unxserv:orac

9. For the "Username:" field, enter

scott

10. For the "Password:" field, enter

tiger

11. Select OK.

12. Double-click on the Query icon.

13. Click on Query Assist.

14. At the "Table:" field, click on the DOWN arrow.

15. Select SCOTT.EMP.

16. In the "Columns:" field, select EMPNO → Select → Add.

17. Select ENAME → Select → Add.

18. Select JOB → Select → Add.

19. Select OK.

20. Click on Test Query: Rows display on the screen.

21. To exit Forest & Trees, select Exit → Query Results.

22. At "Exit Edit Query:" select CANCEL.

23. From the menu bar, select File → Exit.

24. At "Save Changes:" select NO.
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Operating the TCP/IP Platform
The following sections provide instructions for starting and stopping the
TCP/IP Platform.

Starting the SCO UNIX Database Server

To start the SCO UNIX database server, complete the following steps:   

1. Boot the system in multiuser mode.

2. To log in as the user oracle, enter

oracle

3. Then enter the password, for example:

oraclepswd

4. Start SQL*Net TCP/IP for UNIX by entering

tcpctl start

5. Start the ORACLE administrator utility, sqldba, by entering

sqldba

6. Start the ORACLE RDBMS by entering

startup

7. To stop the sqldba utility, enter

exit
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Starting the NetWare Server

To start the NetWare server, complete the following steps:   

1. Boot the NetWare server.

2. Change directories to the directory where you copied your installation
files. For example:

cd \netware

3. Then enter

server

Starting the Windows Workstation

To start the workstation, complete the following steps:   

1. Boot the workstation.

2. Start Microsoft Windows by entering

win
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Stopping the SCO UNIX Database Server

To stop the SCO UNIX database server, complete the following steps:   

1. Start the ORACLE administrator utility, sqldba by entering

sqldba

2. Stop the ORACLE RDBMS by entering

shutdown

3. Exit the sqldba utility by entering

exit

4. Log in as root by entering

root

5. Enter the root password, for example:

rootpswd

6. Stop the SCO UNIX server by entering

shutdown -g0 -y

Stopping The NetWare Server

To stop the NetWare server, complete the following steps:   

1. From the server console, enter

down

2. Exit by entering

exit

Stopping the Windows Workstation

To exit from Microsoft Windows select File → Exit from the menu bar.
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